Friday, August 7, 2009

WES 2009 Installation Error

While installing Windows Embedded Standard 2009 you probably already experienced different errors.

  • Error 1:
    An error occurs, but no details are provided, and the system revert the complete installation of the tools. In this case it means probably that the WES Iso access run into time out, really plausible while installing the tools through a network share. In this case, burn the DVD and restart installation.
  • Error 2:
    After the tools installed, the installer is updating the content of the component repository. The repository is always located here \\device name\Repositories (where device name is the name of the host computer). This folder is a shared folder on the system and depending on the security settings on your computer this share can potentially write protected by default. For this reason installation tool is no capable to copy the files to the folder and you will have the following error message.









    To Fix this, simply change the share properties and it the retry button.
Hope this will helps you to install the tools :-)
- Nicolas

1 comment:

Joe Broxson (Adeneo Corp) said...

Good posting Nicolas,

I have run into problem number 2 myself before, and I've seen customers run into a similar scenario:

They install while connected to the network, but then cannot build when disconnected.

The solution in this case is to make sure there is always some sort of network connection available. Tool like VMWare and VirtualPC will install a virtual network that are always connected. By having that virtual network in place, you can always connect to \\[machine-name]\Repository and will avoid those build failures.